Announcement

Collapse
No announcement yet.

Bug when I modify the column of a table, and that I put a column to DEFAULT NULL.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bug when I modify the column of a table, and that I put a column to DEFAULT NULL.

    Hello,
    I have a bug when I modify the column of a table, and that I put a column to DEFAULT NULL.
    When I then click on this column, then I DEFAULT to empty string, and if I modify this column again and I save, the DEFAULT NULL is replaced by DEFAULT empty string.
    How to fix this bug please?
    Thank you.


    I do not speak English well, here is my message in French:

    Bonjour,
    J'ai un bug lorsque je modifie la colonne d'une table, et que je met une colonne à DEFAULT NULL.
    Lorsque ensuite je clique sur cette colonne, ensuite j'ai DEFAULT à empty string, et si je modifie encore cette colonne et que je sauvegarde, le DEFAULT NULL est remplacé par DEFAULT empty string.
    Comment régler ce bug SVP ?
    Merci.

  • #2
    Would you please provide us the following information? You can send it to our support center - https://help.navicat.com/hc/en-us

    1. Your Navicat version, e.g. Navicat for MySQL (Windows) 11.2.16
    2. The sql file of the original table? In Navicat main window, right-click your table and choose Dump SQL File.
    3. Detailed steps to reproduce the problem.

    Comment


    • #3
      The version is: Navicat for MariaDB 11.2.16.
      But I have the same problem with Navicat Premium version, the problem exists only with mariadb, with mysql it doesn't happen.

      When I'm editing a table, I set the default value for a colomn to Null, I save, then it shows Empty String. If I save again the default value switchs to ''.

      PS: I do not have this problem with MariaDB 10.1, only with version 10.2

      How to make it save as Null without it switching to Empty String?





      _I do not speak English well, here is my message in French:

      La version est : Navicat for MariaDB 11.2.16.
      Mais j'ai le même problème avec la version Navicat Premium, le problème n'existe qu'avec mariadb, avec mysql ça n'arrive pas.

      Lorsque je suis en train d'éditer une table, je mets la valeur par défaut pour un colomn à Null, j'enregistre, puis il affiche la chaîne vide. Si je sauvegarde à nouveau la valeur par défaut passe à ''.

      PS: je n'ai pas ce problème avec MariaDB 10.1, qu'avec la version 10.2

      Comment faire pour enregistrer comme Null sans passer à la chaîne vide?
      Last edited by stephweb; 01-02-2018, 10:00 PM.

      Comment


      • #4
        Thanks for your reply. I have replied your ticket. Please check your email inbox.

        Comment

        Working...
        X