Announcement

Collapse
No announcement yet.

Navicat 12.0.*, queries fail after tab left open for several minutes

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Navicat 12.0.*, queries fail after tab left open for several minutes

    Hi,

    Using Navicat 12 of Mac OS Sierra.

    Version 12.0.16 is now available for me and I have updated.

    Another problem I’m having is as follows:

    1. Start Navicat.
    2. Connect to a server and open a database.
    3. Run a query… at this point all fine and query result are returned.
    4. Leave it for a few minutes and run the same query… Navicat hands, looking as if its executing the query, but it never completes and no results are returned.
    5. Clicking the ‘stop’ button does not still leave the tab in a state where it looks like it is trying to execute the query and the tab cannot be closed.
    6. If I open a new query tab on the same connection and database I can immediately run a query again. But the same will happen, if I leave it for a few minutes and run the query again, it will fail.
    7. I end up in a situation with many unresponsive tabs which every so often I just have to kill Navicat to get rid of.

    Please could you advise on what the issue is here, and if a fix is immanent.


    Cheers,
    Greg.

  • #2
    Hi Greg,

    I have replied your ticket #21367 by email. Please check your inbox.

    Comment


    • #3
      Originally posted by mayho View Post
      Hi Greg,

      I have replied your ticket #21367 by email. Please check your inbox.
      Thanks, I've tested the pre-release version, but no joy I'm afraid, still the same problem.

      :wq

      Comment


      • #4
        Hi Greg,

        Our development team is investigating on the reported issue. We get back to you when there is any news.

        Comment


        • #5
          As information for other users, the Navicat support team sent me the following request:

          -------------------
          Dear xxxx,

          Would you please check whether the Keepalive interval option has enabled (Control-click your connection and choose Edit Connection > Advanced tab)? If it is enabled, please disable it to see if it can solve the problem.

          Should you have any further questions, please feel free to contact us.
          -------------------


          And my response:

          -------------------
          Hi,


          I believe that previously I had the keep alive setting unchecked, but checked it on a connection a few weeks ago to see if it would help. To test this morning I:

          1. Started a fresh instance of Navicat
          2. Edited a connection and unchecked the keep alive setting.
          3. Open the connection
          4. Ran a query and got a result immediately.
          5. Left Navicat for approximately 3 - 4 minutes.
          6. Returned to Navicat and hit command+r to run the query agin, the query hung.

          I can now open a new query on that same connection and it will run fine, unless left for approx 3 minutes, at which point that query window will lock up to. There is no way of clearing the query windows with these ‘running’ queries that don’t ever return, other than doing a force quick of Navicat.

          The software is simply unusable for my business at this stage and I have had to switch to using MySql Workbench. Admittedly the interface to Workbench isn’t as polished, but it is reliable and usable, much like older versions of Navicat were to me. Note the the databases and connection in MySQL Workbench have been setup in exactly the same way (over ssh) as in Navicat, and I can leave them for days, before returning and running a query and getting an immediate response.

          I would be grateful if you could advise on how I could claim a refund for my purchase of version 12 of Navicat, as it is clearly not fit for purpose at this stage.

          -------------------

          Comment


          • #6
            Hi Greg,

            I have replied your ticket #21367 by email. Please check your inbox.

            Comment


            • #7
              Hi mayho,

              I have the same problem that Greg brought up except mine is for NaviCat for SQL Server. Please provide a solution or a method on how to claim a refund for my license as well.

              Roberto

              Comment


              • #8
                Hi Roberto,

                I am sorry that our development team is still investigating on the reported issue.We will contact you if there is any news.

                For the refund request, please submit it to our support center - https://help.navicat.com/hc/en-us , and we will reply you through email.

                Comment

                Working...
                X