Announcement

Collapse
No announcement yet.

Invalid argument in ssh_options_set

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Invalid argument in ssh_options_set

    Since I upgraded to version 12 on my MacBook Pro, all of my server connections that use SSH tunnels have stopped working. When I go to my old MacBook Air with an older version of Navicat, they all still work. I have tried recreating them, etc. with no luck.

    They are connections to 4 different servers including a virtual MySQL service at Rackspace. I always get the same error when I try to establish the connection, it is "11 Invalid argument in ssh_options_set". I have tried checking on and off all of the possible settings in the SSH tab of the connection setup. I can still SSH to all of these servers directly from Terminal (on my MacBook Pro) and there does not seem to be any problems with the servers (and I can still connect to them with my old MacBook using Navicat).

    Any help would help to fix this or to find a work-around would be greatly appreciated.

  • #2
    Hi craig.nakamoto,

    Could you please provide us screenshots showing the connection settings? (i.e. General, Advanced and SSH tabs)

    You can send the information to our support center - https://help.navicat.com/hc/en-us/requests/new

    Comment


    • #3
      I have this problem too, Navicat Premium 12.1.23 on macOS Mojave 10.14.5
      What to do?

      Comment


      • #4
        Hi MrMacvos,

        Could you please send your issue to our support center - https://help.navicat.com/hc/en-us/requests/new ?

        Please provide the following information in the ticket:

        1. Does the problem only happen on version 12.1.23?
        2. Which previous version that works properly?
        3. Screenshots showing the connection settings (i.e. General, Advanced, SSH tabs). To open the connection window, control-click your connection and select Edit Connection.

        Comment

        Working...
        X