Announcement

Collapse
No announcement yet.

CREATE DEFINER Removal

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • CREATE DEFINER Removal

    When I try to connect to an Amazon RDS server, I cannot transfer functions between servers because there are permission problems on the DEFINER='root@localhost'. Is there a way to have Navicat suppress those definers when transferring data?

  • #2
    We have improved the reported situation in v12.1 . Please feel free to try it - https://navicat.com/en/download/navicat-for-mysql

    In v12.1, please uncheck "Use DDL from SHOW CREATE TABLE" in the Options tab of the Data Transfer window.

    Comment

    Working...
    X