Announcement

Collapse
No announcement yet.

Max length export query?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Max length export query?

    Hello Navicat Community,

    I'm trying to export a lot of data from my Oracle database. I've got a query to do that, which has a lot of subqueries and joins and stuff like that. When I run this query in the query window everything works fine and I get 71.000 records in my result tab. Then I save this query and press the Export button to get these rows in a .csv file. I select the query again in the export wizard and tell the wizard where the .csv file should be saved. I check the last settings and then press the start button. Right away I get error ORA-00936: missing expression.

    Then I look through the error and I notice that my query is truncated. All the characters after char 4080 are just gone. My query is 4261 chars long. I tried removing all the spaces and newlines already (saved my like 200 chars) but I'm still not even close.

    Why is this happening? And how can I fix this, so I can export my stuff? I'm using Navicat for Oracle, Version 11.0.16. It is running on Windows 2008 R2. I'm connecting to an Oracle 10 server.

    Best regards, Cybertinus
    Last edited by Cybertinus; 01-14-2014, 01:49 PM. Reason: Added information about the environment where Navicat is running in.

  • #2
    Could you please provide the query sql?

    Comment

    Working...
    X