Announcement

Collapse
No announcement yet.

Bastiaan ten Broeke

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bastiaan ten Broeke

    Hi,

    I want to export data from a database to a csv file.
    When I do that the dates in the csv file do not have the expected format.
    A date like '2018-09-02' will be exported as '2018-9-2'.
    How can I get the dates to be in the exact format as I need it, thus as 'yyyy-mm-dd'?

    Case:
    When I have the data available in Navicat for PostgreSQL (version 12.0.22 Enterprise) I use the export button (export option), I choose csv file, encoding is '65001 - [utf-8] Unicode (UTF-8)
    At the format I select
    Date Order: YMD
    Date Delimiter: -
    Time Delimiter: ':'
    Decimal Symbol: .

    When I open the export file in a text editor the dates are like '2018-9-2' so I am missing the 0's to get a format with constant number of characters like '2018-09-02'.
    I looked for options to set the output format like this but cannot find it.
    I use a macbook with OS X El Capitan version 10.11.6.

  • #2
    Currently, macOS version does not support your mentioned feature. I have forwarded your request to our development team. We will consider to support it in future. I will contact you if there is any news.

    Comment


    • Bastiaan ten Broeke
      Editing a comment
      Thanks for your information. I look forward to the support on this feature. I was used to get dates in the mentioned format, it has a great benefit to have dates written with a standard length.

  • #3
    We are glad to tell you that Navicat for PostgreSQL (macOS) version 12.0.28 has been released and added "Zero Padding Date" option in Export Wizard. To, you can simply choose Navicat for PostgreSQL -> Check for Updates from the menu bar.

    Comment

    Working...
    X