Announcement

Collapse
No announcement yet.

Stored Procedure Default Values Not Recognized in Navicat 11

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Stored Procedure Default Values Not Recognized in Navicat 11

    I've created stored procedures in Navicat 11 with default values for parameters as:

    ALTER PROCEDURE [Contracts].[TeamRangeValues]
    @Entity nchar(3) = "Bob", -- Default Value for convenience during testing
    @BidCurrencyCode nchar(3) = "USD", -- Default Value for convenience during testing
    @MeasurableID INT = 1, -- Default Value for convenience during testing
    @MeasurableCalculationDateTime DATETIME2 = '2016-01-04 00:00:00.0000000' -- Default Value for convenience during testing


    The default values input fine when run in SSMS but when the sp is executed in Navicat only the DATETIME2 seems to be accepted (result set in Navicat is blank). I've tried " , ' , " ' etc all to no avail.

    Thoughts (other than continue switching screens)?


  • #2
    Please try to choose all parameters as "DEFAULT" in Input Parameter box when you execute the procedure.

    Comment


    • #3
      Is there any way to make Navicat automatically use the default values (rather than having to click the drop down box for each one upon execution)?

      Comment


      • #4
        I am sorry that Navicat does not provide your mentioned feature. Your request has been forwarded to our development team. Thanks for your advice.

        Comment

        Working...
        X