Announcement

Collapse
No announcement yet.

Can't copy image into Navicat BLOB field

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't copy image into Navicat BLOB field

    There is a list of steps about how to copy a JPEG (or other image file) into a Navicat blob field, but I cannot get it to work.

    Clicking in a BLOB field in Navicat table view does not show me the "..." buttons where I can select to "import".

    Is this a bug?

    I'm using the latest version of Navicat 11.2.15 on Mac.

    Thanks for any suggestions on how to make this work.

    - o

  • #2
    Please import the file using the Image Editor. You can refer to this video for details. https://www.youtube.com/watch?v=XNAhghYSOpo

    Comment


    • #3
      Thanks, but this video doesn't match what happens in Navicat at all.

      When I switch to view images in grid I get lots of spinning waits on the mac. Everything in a table with only about 50 rows slows down where it is not responsive any longer.

      I then tried to click and double click on one of the Null BLOB fields but it's never selected or puts the cursor in there (after I switched to view images in grid view.)

      Finally, clicking the "Text" dropdown doesn't do "anything". No three options appear.

      NOTHING HAPPENS.

      Not sure when that video was made but the latest version of Navicat Premium for the Mac does not behave this way or (for me) work at all for importing images.

      Have you tested this?

      Thanks.

      Comment


      • #4
        Please do not show the images in grid if your BLOB field data is large.

        To open the Image editor at the bottom, please click and hold the Text button a few seconds to see if the drop-down menu appears. If yes, please click Image.

        If the menu does not appear, please provide us the Console Log message after reproducing the problem. Open the Console application located in /Applications/Utilities folder, copy the messages there.

        Comment


        • #5
          Yes, that worked!

          The trick was to hold the Text button itself down and not click the drop down. A bit confusing and counter-intuitive, but it works fine.

          (and turn off the show images in grid as that slowed Navicat to the point of non-usability.)

          Thank you again!!!

          Comment

          Working...
          X