Announcement

Collapse
No announcement yet.

Navicat Premium 12.0.4 - Bugs importing access database to mysql using import wizard

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Navicat Premium 12.0.4 - Bugs importing access database to mysql using import wizard

    I'm experiencing a problem uploading an access database to a mysql database using the import wizard. I'm trying to upload 5 tables. In step 1 of the import process I choose MS Access Database. In step 2 I choose the local mdb file. In step 3, if I select all five tables, when I get to step 4/7 Map Tables, Navicat correctly chooses the Target Table, but thinks the tables are new (they're not). On the next step, the Target Table Fields are blank, despite being exactly the same in the source as the destination. There is also no option to choose a field - the menu handle doesn't respond to clicking. On one attempt the handles didn't appear, and I was able to free type the field names. But either way the import fails with the message
    [ERR] Cannot create table [Customer]: 1050 - Table 'Customer' already exists

    In step 3, if I select just one table, it still marks the table as new, but it will sometimes match the fields, and sometime not match them and not allow choosing anything, as above. If it recognizes the field names, and then I choose Copy in step 6, it fail as above. If it doesn't recognize the fields, and I proceed with copy, it will successfully truncate the tables, but not add any records (no fields are mapped).

    Anyone else experiencing this or found any workarounds?
Working...
X