Announcement

Collapse
No announcement yet.

Navicat 12 - Import function does not auto-increment Identity column

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Navicat 12 - Import function does not auto-increment Identity column

    Hi there,

    In previous Navicat Premium versions you could just import a file that did not have the Identity column values and Navicat would just add and auto-increment by itself. However with version 12 (64-bit) the same import profile results in:
    [ERR] [42000] [Microsoft][SQL Server Native Client 10.0][SQL Server]Explicit value must be specified for identity column in table 'tbl_slm_storage_metingen' either when IDENTITY_INSERT is set to ON or when a replication user is inserting into a NOT FOR REPLICATION identity column. (545)

    But IDENTITY_INSERT is set to OFF and NOT FOR REPLICATION is disabled!

    Does the import feature of Navicat 12 automatically set IDENTITY_INSERT is set to ON for the duration of the import Import? And if so is that by design?

    It is quite annoying. Now I either have to create and identity column in the import with the appropriate values or resort to Navicat 11 - 32-bit which is still also on my system.

    Greetings, Eric

  • #2
    Hi Eric,

    Our development team is investigating on the reported problem. We will contact you after investigation.

    Comment


    • #3
      Hi there,

      FYI: There was an update today, version 12.0.17 did not solve that problem.

      Comment


      • #4
        Hi Eric,

        Sorry. We are still investigating on the reported problem.

        Comment


        • #5
          Hi Eric,

          We are able to identify the problem and our development team is trying to fix it. We will contact you after the bug is fixed.

          Comment

          Working...
          X