Announcement

Collapse
No announcement yet.

Navicat 12 - Import function does not auto-increment Identity column

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Navicat 12 - Import function does not auto-increment Identity column

    Hi there,

    In previous Navicat Premium versions you could just import a file that did not have the Identity column values and Navicat would just add and auto-increment by itself. However with version 12 (64-bit) the same import profile results in:
    [ERR] [42000] [Microsoft][SQL Server Native Client 10.0][SQL Server]Explicit value must be specified for identity column in table 'tbl_slm_storage_metingen' either when IDENTITY_INSERT is set to ON or when a replication user is inserting into a NOT FOR REPLICATION identity column. (545)

    But IDENTITY_INSERT is set to OFF and NOT FOR REPLICATION is disabled!

    Does the import feature of Navicat 12 automatically set IDENTITY_INSERT is set to ON for the duration of the import Import? And if so is that by design?

    It is quite annoying. Now I either have to create and identity column in the import with the appropriate values or resort to Navicat 11 - 32-bit which is still also on my system.

    Greetings, Eric

  • mayho
    replied
    Hi Eric,

    We are glad to tell you that Navicat version 12.0.20 has been released and fixed your reported problem. Please upgrade to this latest version - submit your registered email address on the Customer Center at:

    https://customer.navicat.com

    Or, you can simply choose Help -> Check for Updates from the menu bar.

    Leave a comment:


  • Dep1971
    replied
    Solved with version 12.0.19 and the patched libcc file!

    Leave a comment:


  • mayho
    replied
    Hi Eric,

    We are able to identify the problem and our development team is trying to fix it. We will contact you after the bug is fixed.

    Leave a comment:


  • Dep1971
    replied
    Well I upgraded to the new version...but I cannot test is you solved the problem....because now I cannot connect at all to my databases with that version.
    Attached Files

    Leave a comment:


  • mayho
    replied
    Hi Eric,

    We are glad to tell you that Navicat Premium (Windows) version 12.0.19 has been released and fixed your reported problem. Please upgrade to this latest version - submit your registered email address on the Customer Center at:

    https://customer.navicat.com

    Or, you can simply choose Help -> Check for Updates from the menu bar.

    Leave a comment:


  • mayho
    replied
    Hi Eric,

    We are able to identify the problem and our development team is trying to fix it. We will contact you after the bug is fixed.

    Leave a comment:


  • mayho
    replied
    Hi Eric,

    Sorry. We are still investigating on the reported problem.

    Leave a comment:


  • Dep1971
    replied
    Hi there,

    FYI: There was an update today, version 12.0.17 did not solve that problem.

    Leave a comment:


  • mayho
    replied
    Hi Eric,

    Our development team is investigating on the reported problem. We will contact you after investigation.

    Leave a comment:

Working...
X