Announcement

Collapse
No announcement yet.

Set the format of dates in csv export file

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Set the format of dates in csv export file

    Hi,

    I want to export data from a database to a csv file.
    When I do that the dates in the csv file do not have the expected format.
    A date like '2018-09-02' will be exported as '2018-9-2'.
    How can I get the dates to be in the exact format as I need it, thus as 'yyyy-mm-dd'?

    Case:
    When I have the data available in Navicat Premium (version 12.0.27 Premium) I use the export button (export option), I choose csv file, encoding is '65001 - [utf-8] Unicode (UTF-8)
    At the format I select
    Date Order: YMD
    Date Delimiter: -
    Time Delimiter: ':'
    Decimal Symbol: .

    When I open the export file in a text editor the dates are like '2018-9-2' so I am missing the 0's to get a format with constant number of characters like '2018-09-02'.
    I looked for options to set the output format like this but cannot find it.
    I use a macbook with OS X El Capitan version 10.11.6.

  • Bastiaan ten Broeke
    commented on 's reply
    It works perfectly! Thanks!

  • mayho
    replied
    We are glad to tell you that Navicat Premium (macOS) version 12.0.28 has been released and added "Zero Padding Date" option in Export Wizard. To, you can simply choose Navicat Premium -> Check for Updates from the menu bar.

    Leave a comment:


  • Bastiaan ten Broeke
    commented on 's reply
    Hello Mayho,

    Thanks for your answer to my question.
    I am a bit surprised about this answer however, since I had Navicat Premium running in the past, the 11.2 version, and there it worked fine exporting dates in the format I need. Howcome this issue has come op with recent versions of Navicat?

  • mayho
    replied
    Currently, macOS version does not support your mentioned feature. I have forwarded your request to our development team. We will consider to support it in future. I will contact you if there is any news.

    Leave a comment:

Working...
X