Announcement

Collapse
No announcement yet.

Navicat doesn't work with passwords with special characters

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Navicat doesn't work with passwords with special characters

    I recently downloaded Navicat Premium Trial for Mac and I tried to use it with my MongoDB installation, but it's not working and I'm pretty sure it's because Navicat was not properly designed to support passwords with special characters.

    My MongoDB installation has authentication enabled, but after some failed attempts I tried to use other MongoDB Clients (Robomongo and noSQL Booster) and they all worked fine; only Navicat fails to connect. Then I changed the password on my MongoDB installation to something simpler, without special characters, and I finally managed to connect using Navicat.

    The original password that I was using has special characters like "&" and "@" and it's a shame that Navicat don't support them, since it's a basic and recommended security measure to use strong passwords with special characters. Also, if the database system (MongoDB) supports passwords like that then it only makes sense for Navicat to offer the same support.

  • #2
    Hi hstepan,

    Thanks for reporting this issue to us. We are able to identify the problem and our development team is trying to fix it. We will contact you after the bug is fixed.

    Comment

    Working...
    X