Announcement

Collapse
No announcement yet.

SSH Keepalives

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • SSH Keepalives

    My host closes inactive SSH sessions after 5mins
    When using Navicat Premium to "Use SSH Tunnel" i often find this timeout gets reached and breached
    Closing and reopening the connection seems to be the only way to revive it.
    Not the best when it closes all your query windows!

    Winscp allows you to use keepalives
    Click image for larger version

Name:	2017-06-19_13-35-41.png
Views:	1
Size:	5.0 KB
ID:	4675


    as does Kitty (putty clone with extended functionality)
    Click image for larger version

Name:	2017-06-19_13-41-24.png
Views:	1
Size:	3.4 KB
ID:	4676


    I'll be reverting back to port forwarding through Kitty till this can be addressed. Thanks.
    mh

  • #2
    Hi mhume,

    Please try to enable the Keepalive Interval option and set a value to see if your tunnel timeout. Right-click your connection and choose Edit Connection > Advanced tab.

    Comment


    • #3
      Ok
      That seem to work even if it is a little hidden away in the advanced tab. Thanks

      Next question
      When my computer resumes from sleep any action i try to perform results in the following error message

      Click image for larger version

Name:	2017-06-23_19-50-50.png
Views:	1
Size:	10.1 KB
ID:	4682


      This is due to the SSH session timing out whilst the machine is asleep.
      How do i reconnect the SSH tunnel without having to close the connection first?
      cheers

      Comment


      • #4
        Could you please provide the version number of your Navicat? e.g. 12.0.7

        Comment


        • #5
          Aha
          I was on an older version of 11 (check for update was disabled for some reason)
          I've now updated to v11.2.16 and reconnects after sleep seem to occur correctly
          cheers

          Comment

          Working...
          X