When I click the Check For Updates option a web page loads which says, "Invalid Navicat version!"

I am running 12.0.11 Linux version....